CRAN Package Check Results for Package NMproject

Last updated on 2022-06-27 01:49:57 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.6.7 23.42 229.18 252.60 OK
r-devel-linux-x86_64-debian-gcc 0.6.7 14.87 164.45 179.32 OK
r-devel-linux-x86_64-fedora-clang 0.6.7 289.56 OK
r-devel-linux-x86_64-fedora-gcc 0.6.7 306.21 OK
r-devel-windows-x86_64 0.6.7 296.00 335.00 631.00 OK
r-patched-linux-x86_64 0.6.7 29.58 214.88 244.46 OK
r-release-linux-x86_64 0.6.7 22.91 212.37 235.28 OK
r-release-macos-arm64 0.6.7 98.00 OK
r-release-macos-x86_64 0.6.7 171.00 OK
r-release-windows-x86_64 0.6.7 279.00 310.00 589.00 OK
r-oldrel-macos-arm64 0.6.7 107.00 OK
r-oldrel-macos-x86_64 0.6.7 59.00 OK
r-oldrel-windows-ix86+x86_64 0.6.7 35.00 157.00 192.00 ERROR

Check Details

Version: 0.6.7
Check: tests
Result: ERROR
     Running 'testthat.R' [24s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(NMproject)
     >
     > test_check("NMproject")
     Package: localanalysis
     Title: What the Package Does (One Line, Title Case)
     Version: 0.0.0.9000
     [email protected] (parsed):
     * First Last <[email protected]> [aut, cre] (YOUR-ORCID-ID)
     Description: What the package does (one paragraph).
     License: `use_mit_license()`, `use_gpl3_license()` or friends to pick a
     license
     Encoding: UTF-8
     Roxygen: list(markdown = TRUE)
     RoxygenNote: 7.2.0
     Error : only `math_method = 'mathjax'` is supported with earlier version than Pandoc 2.0
     Package: localanalysis
     Title: What the Package Does (One Line, Title Case)
     Version: 0.0.0.9000
     [email protected] (parsed):
     * First Last <[email protected]> [aut, cre] (YOUR-ORCID-ID)
     Description: What the package does (one paragraph).
     License: `use_mit_license()`, `use_gpl3_license()` or friends to pick a
     license
     Encoding: UTF-8
     Roxygen: list(markdown = TRUE)
     RoxygenNote: 7.2.0
     Error : only `math_method = 'mathjax'` is supported with earlier version than Pandoc 2.0
     Package: localanalysis
     Title: What the Package Does (One Line, Title Case)
     Version: 0.0.0.9000
     [email protected] (parsed):
     * First Last <[email protected]> [aut, cre] (YOUR-ORCID-ID)
     Description: What the package does (one paragraph).
     License: `use_mit_license()`, `use_gpl3_license()` or friends to pick a
     license
     Encoding: UTF-8
     Roxygen: list(markdown = TRUE)
     RoxygenNote: 7.2.0
     Error : only `math_method = 'mathjax'` is supported with earlier version than Pandoc 2.0
     [ FAIL 4 | WARN 0 | SKIP 0 | PASS 11 ]
    
     == Failed tests ================================================================
     -- Error (test-basic.R:9:3): Project has basic functionality -------------------
     <callr_status_error/callr_error/rlib_error_2_0/rlib_error/error/condition>
     Error: callr subprocess failed: only `math_method = 'mathjax'` is supported with earlier version than Pandoc 2.0
     Backtrace:
     x
     1. +-NMproject:::with_temp_git_config(nm_create_analysis_project(proj_path)) at test-basic.R:9:2
     2. | \-base::eval(code)
     3. \-NMproject::nm_create_analysis_project(proj_path)
     4. +-base::suppressMessages(devtools::build_readme(path = path))
     5. | \-base::withCallingHandlers(...)
     6. \-devtools::build_readme(path = path)
     7. \-devtools::build_rmd(...)
     8. \-callr::r_safe(...)
     9. \-callr:::get_result(output = out, options)
     10. \-throw(newerr, parent = remerr[[2]])
     -- Error (test-basic.R:47:3): set up -------------------------------------------
     Error in `nm_create_analysis_project(proj_path)`: Directory already exists. Aborting.
     Backtrace:
     x
     1. +-NMproject:::with_temp_git_config(nm_create_analysis_project(proj_path)) at test-basic.R:47:2
     2. | \-base::eval(code)
     3. \-NMproject::nm_create_analysis_project(proj_path)
     -- Error (test-manual_edit.R:11:3): manual_edit --------------------------------
     <callr_status_error/callr_error/rlib_error_2_0/rlib_error/error/condition>
     Error: callr subprocess failed: only `math_method = 'mathjax'` is supported with earlier version than Pandoc 2.0
     Backtrace:
     x
     1. +-NMproject:::with_temp_git_config(nm_create_analysis_project(proj_path)) at test-manual_edit.R:11:2
     2. | \-base::eval(code)
     3. \-NMproject::nm_create_analysis_project(proj_path)
     4. +-base::suppressMessages(devtools::build_readme(path = path))
     5. | \-base::withCallingHandlers(...)
     6. \-devtools::build_readme(path = path)
     7. \-devtools::build_rmd(...)
     8. \-callr::r_safe(...)
     9. \-callr:::get_result(output = out, options)
     10. \-throw(newerr, parent = remerr[[2]])
     -- Error (test-theopp.R:11:3): run and post ------------------------------------
     <callr_status_error/callr_error/rlib_error_2_0/rlib_error/error/condition>
     Error: callr subprocess failed: only `math_method = 'mathjax'` is supported with earlier version than Pandoc 2.0
     Backtrace:
     x
     1. +-NMproject:::with_temp_git_config(nm_create_analysis_project(proj_path)) at test-theopp.R:11:2
     2. | \-base::eval(code)
     3. \-NMproject::nm_create_analysis_project(proj_path)
     4. +-base::suppressMessages(devtools::build_readme(path = path))
     5. | \-base::withCallingHandlers(...)
     6. \-devtools::build_readme(path = path)
     7. \-devtools::build_rmd(...)
     8. \-callr::r_safe(...)
     9. \-callr:::get_result(output = out, options)
     10. \-throw(newerr, parent = remerr[[2]])
    
     [ FAIL 4 | WARN 0 | SKIP 0 | PASS 11 ]
     Error: Test failures
     Execution halted
Flavor: r-oldrel-windows-ix86+x86_64