CRAN Package Check Results for Package Require

Last updated on 2022-01-16 01:07:12 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.0.13 5.65 212.51 218.16 OK
r-devel-linux-x86_64-debian-gcc 0.0.13 5.27 167.09 172.36 OK
r-devel-linux-x86_64-fedora-clang 0.0.13 246.22 NOTE
r-devel-linux-x86_64-fedora-gcc 0.0.13 1112.66 NOTE
r-devel-windows-x86_64-new-UL 0.0.13 46.00 701.00 747.00 ERROR
r-devel-windows-x86_64-new-TK 0.0.13 ERROR
r-patched-linux-x86_64 0.0.13 7.32 191.82 199.14 OK
r-release-linux-x86_64 0.0.13 5.31 182.27 187.58 OK
r-release-macos-arm64 0.0.13 OK
r-release-macos-x86_64 0.0.13 OK
r-release-windows-ix86+x86_64 0.0.13 11.00 112.00 123.00 OK
r-oldrel-macos-x86_64 0.0.13 OK
r-oldrel-windows-ix86+x86_64 0.0.13 12.00 108.00 120.00 OK

Check Details

Version: 0.0.13
Check: for non-standard things in the check directory
Result: NOTE
    Found the following files/directories:
     ‘4.2’
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.0.13
Check: tests
Result: ERROR
     Running 'test-all.R' [123s]
    Running the tests in 'tests/test-all.R' failed.
    Complete output:
     > library(testit)
     > test_pkg("Require")
     Installing: TimeWarp
     -- Installing TimeWarp -- (1 of 1. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'D:/temp/RtmpOsdfwI/Require/test1/4.2'
     (as 'lib' is unspecified)
     trying URL 'https://cloud.r-project.org/bin/windows/contrib/4.2/TimeWarp_1.0.15.zip'
     Content length 145100 bytes (141 KB)
     ==================================================
     downloaded 141 KB
    
     package 'TimeWarp' successfully unpacked and MD5 sums checked
    
     The downloaded binary packages are in
     D:\temp\RtmpOsdfwI\downloaded_packages
     Loading required package: TimeWarp
     Detaching is fraught with many potential problems; you may have to restart your session if things aren't working
     available.packages() does not have correct information on package dependencies for sdfd; downloading tar.gz
     sdfd dependencies not found on CRAN; perhaps incomplete description? On GitHub?
     available.packages() does not have correct information on package dependencies for data.tt; downloading tar.gz
     data.tt dependencies not found on CRAN; perhaps incomplete description? On GitHub?
     Installing: data.tt
     -- Installing data.tt -- (1 of 1. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'D:/temp/RtmpwZom43/RLIBS_308681f702651/4.2'
     (as 'lib' is unspecified)
     deps is provided; useAllInSearch will be set to FALSE
     deps is provided; useAllInSearch will be set to FALSE
     Installing: data.table
     Detaching is fraught with many potential problems; you may have to restart your session if things aren't working
     -- Installing data.table -- (1 of 1. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'D:/temp/RtmpOsdfwI/Require/RtmpOsdfwI/4.2'
     (as 'lib' is unspecified)
     trying URL 'https://www.r-project.org/nosvn/winutf8/ucrt3/CRAN/bin/windows/contrib/4.2/data.table_1.14.2.zip'
     length 2233008 bytes (2.1 MB)
     ==================================================
     downloaded 2.1 MB
    
     package 'data.table' successfully unpacked and MD5 sums checked
    
     The downloaded binary packages are in
     D:\temp\RtmpOsdfwI\downloaded_packages
     did not contain Require source code
     installing the source package 'Require'
    
     trying URL 'https://cloud.r-project.org/src/contrib/Require_0.0.13.tar.gz'
     Content length 81092 bytes (79 KB)
     ==================================================
     downloaded 79 KB
    
     * installing *source* package 'Require' ...
     ** package 'Require' successfully unpacked and MD5 sums checked
     ** using staged installation
     ** R
     ** inst
     ** byte-compile and prepare package for lazy loading
     ** help
     *** installing help indices
     ** building package indices
     ** testing if installed package can be loaded from temporary location
     ** testing if installed package can be loaded from final location
     ** testing if installed package keeps a record of temporary installation path
     * DONE (Require)
    
     The downloaded source packages are in
     'D:\temp\Rtmp2pYFR9\downloaded_packages'
     Installing: remotes, data.table, Require
     Detaching is fraught with many potential problems; you may have to restart your session if things aren't working
     -- Installing remotes -- (1 of 3. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'D:/temp/RtmpOsdfwI/Require/RtmpOsdfwI/4.2'
     (as 'lib' is unspecified)
     trying URL 'https://cloud.r-project.org/bin/windows/contrib/4.2/remotes_2.4.2.zip'
     Content length 398674 bytes (389 KB)
     ==================================================
     downloaded 389 KB
    
     package 'remotes' successfully unpacked and MD5 sums checked
    
     The downloaded binary packages are in
     D:\temp\RtmpOsdfwI\downloaded_packages
     -- Installing data.table -- (2 of 3. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'D:/temp/RtmpOsdfwI/Require/RtmpOsdfwI/4.2'
     (as 'lib' is unspecified)
     trying URL 'https://www.r-project.org/nosvn/winutf8/ucrt3/CRAN/bin/windows/contrib/4.2/data.table_1.14.2.zip'
     length 2233008 bytes (2.1 MB)
     ==================================================
     downloaded 2.1 MB
    
     package 'data.table' successfully unpacked and MD5 sums checked
    
     The downloaded binary packages are in
     D:\temp\RtmpOsdfwI\downloaded_packages
     -- Installing Require -- (3 of 3. Estimated time left: 8 secs; est. finish: 2022-01-13 19:04:32)
     Duplicate packages are Required; discarding older, or unavailable
     Package packageFullName keep installResult
     1: data.table data.table TRUE TRUE
     2: data.table data.table FALSE TRUE
     Duplicate packages are Required; discarding older, or unavailable
     Package packageFullName keep installResult
     1: data.table data.table TRUE TRUE
     2: data.table data.table FALSE TRUE
     Detaching is fraught with many potential problems; you may have to restart your session if things aren't working
     .libPaths() is now: D:/temp/RtmpOsdfwI/Require/RtmpOsdfwI/4.2, D:/RCompile/recent/R/library
     Loading required package: data.table
     .libPaths() is now: D:/temp/RtmpwZom43/RLIBS_308681f702651/4.2, D:/RCompile/recent/R/library/4.2, D:/RCompile/recent/R/library
     Updating .Rprofile; this will set new libPaths for R packages even after restarting R
     .libPaths() is now: D:/temp/RtmpOsdfwI/newProjectLib/4.2, D:/RCompile/recent/R/library
     removing custom libPaths in .Rprofile
     .libPaths() is now: D:/temp/RtmpwZom43/RLIBS_308681f702651/4.2, D:/RCompile/recent/R/library/4.2, D:/RCompile/recent/R/library
     .libPaths() is now: D:/temp/RtmpwZom43/RLIBS_308681f702651, D:/RCompile/recent/R/library
     Placing copy of Require in D:/temp/RtmpOsdfwI/Require/setupTests
     Placing copy of remotes in D:/temp/RtmpOsdfwI/Require/setupTests
     Placing copy of data.table in D:/temp/RtmpOsdfwI/Require/setupTests
     Updating .Rprofile; this will set new libPaths for R packages even after restarting R
     .libPaths() is now: D:/temp/RtmpOsdfwI/Require/setupTests/4.2, D:/RCompile/recent/R/library
     removing custom libPaths in .Rprofile
     .libPaths() is now: D:/temp/RtmpwZom43/RLIBS_308681f702651, D:/RCompile/recent/R/library
     This is getOption('Require.RPackageCache')
     This is NULL
     Updating .Rprofile; this will set new libPaths for R packages even after restarting R
     .libPaths() is now: D:/temp/RtmpOsdfwI/Require/setupTests/4.2, D:/RCompile/recent/R/library
     removing custom libPaths in .Rprofile
     .libPaths() is now: D:/temp/RtmpwZom43/RLIBS_308681f702651, D:/RCompile/recent/R/library
     Getting dates of current CRAN packages
     available.packages() does not have correct information on package dependencies for Require because they are Archive versions; downloading their respective tar.gz files
     Called from: (function (pkgURL, pkgTD)
     {
     url <- file.path(repos, srcContrib, "/Archive", pkgURL)
     url2 <- file.path(repos, srcContrib, basename(pkgURL))
     tf <- tempfile()
     haveFile <- suppressWarnings(tryCatch(download.file(url,
     tf, quiet = TRUE), error = function(x) tryCatch(download.file(url2,
     tf, quiet = TRUE), error = function(y) FALSE)))
     if (!file.exists(tf))
     browser()
     untar(tarfile = tf, exdir = dirname(pkgTD))
     filesToDel <- dir(pkgTD, recursive = TRUE, full.names = TRUE,
     include.dirs = TRUE)
     filesToDel <- filesToDel[grep("^DESCRIPTION$", basename(filesToDel),
     invert = TRUE)]
     unlink(filesToDel, recursive = TRUE)
     })(pkgURL = dots[[1L]][[1L]], pkgTD = dots[[2L]][[1L]])
     Browse[1]> debug: untar(tarfile = tf, exdir = dirname(pkgTD))
     Browse[2]> /usr/bin/tar: D\:\\temp\\RtmpOsdfwI\\filec6487d134d84: Cannot open: No such file or directory
     /usr/bin/tar: Error is not recoverable: exiting now
     debug: filesToDel <- dir(pkgTD, recursive = TRUE, full.names = TRUE,
     include.dirs = TRUE)
     Warning message:
     In untar(tarfile = tf, exdir = dirname(pkgTD)) :
     'd:/rtools42/usr/bin/tar -xf "D:\temp\RtmpOsdfwI\filec6487d134d84" -C "D:/temp/RtmpOsdfwI/Require/MEDTWJ"' returned error code 2
     Browse[2]> debug: filesToDel <- filesToDel[grep("^DESCRIPTION$", basename(filesToDel),
     invert = TRUE)]
     Browse[2]> debug: unlink(filesToDel, recursive = TRUE)
     Browse[2]> Error from message(pkg, " dependencies not found on CRAN; perhaps incomplete description? On GitHub?")
     Error in message(pkg, " dependencies not found on CRAN; perhaps incomplete description? On GitHub?") :
     object 'pkg' not found
     Calls: test_pkg ... pkgDepArchive -> lapply -> FUN -> message -> .makeMessage -> lapply
     Execution halted
Flavor: r-devel-windows-x86_64-new-UL

Version: 0.0.13
Check: tests
Result: ERROR
     Running 'test-all.R'
    Running the tests in 'tests/test-all.R' failed.
    Complete output:
     > library(testit)
     > test_pkg("Require")
     Installing: TimeWarp
     -- Installing TimeWarp -- (1 of 1. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/test1/4.2'
     (as 'lib' is unspecified)
     trying URL 'https://cloud.r-project.org/bin/windows/contrib/4.2/TimeWarp_1.0.15.zip'
     Content length 145100 bytes (141 KB)
     ==================================================
     downloaded 141 KB
    
     package 'TimeWarp' successfully unpacked and MD5 sums checked
    
     The downloaded binary packages are in
     C:\r_packages\pkgcheck\CRAN\Require\tmp\Rtmp8YwXXB\downloaded_packages
     Loading required package: TimeWarp
     Detaching is fraught with many potential problems; you may have to restart your session if things aren't working
     available.packages() does not have correct information on package dependencies for sdfd; downloading tar.gz
     sdfd dependencies not found on CRAN; perhaps incomplete description? On GitHub?
     available.packages() does not have correct information on package dependencies for data.tt; downloading tar.gz
     data.tt dependencies not found on CRAN; perhaps incomplete description? On GitHub?
     Installing: data.tt
     -- Installing data.tt -- (1 of 1. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'C:/r_packages/pkgcheck/CRAN/Require/Require.Rcheck/4.2'
     (as 'lib' is unspecified)
     deps is provided; useAllInSearch will be set to FALSE
     deps is provided; useAllInSearch will be set to FALSE
     Installing: data.table
     Detaching is fraught with many potential problems; you may have to restart your session if things aren't working
     -- Installing data.table -- (1 of 1. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/Rtmp8YwXXB/4.2'
     (as 'lib' is unspecified)
     trying URL 'https://www.r-project.org/nosvn/winutf8/ucrt3/CRAN/bin/windows/contrib/4.2/data.table_1.14.2.zip'
     length 2233008 bytes (2.1 MB)
     ==================================================
     downloaded 2.1 MB
    
     package 'data.table' successfully unpacked and MD5 sums checked
    
     The downloaded binary packages are in
     C:\r_packages\pkgcheck\CRAN\Require\tmp\Rtmp8YwXXB\downloaded_packages
     did not contain Require source code
     installing the source package 'Require'
    
     trying URL 'https://cloud.r-project.org/src/contrib/Require_0.0.13.tar.gz'
     Content length 81092 bytes (79 KB)
     ==================================================
     downloaded 79 KB
    
     * installing *source* package 'Require' ...
     ** package 'Require' successfully unpacked and MD5 sums checked
     ** using staged installation
     ** R
     ** inst
     ** byte-compile and prepare package for lazy loading
     ** help
     *** installing help indices
     ** building package indices
     ** testing if installed package can be loaded from temporary location
     ** testing if installed package can be loaded from final location
     ** testing if installed package keeps a record of temporary installation path
     * DONE (Require)
    
     The downloaded source packages are in
     'C:\r_packages\pkgcheck\CRAN\Require\tmp\Rtmps9mJWA\downloaded_packages'
     Installing: remotes, data.table, Require
     Detaching is fraught with many potential problems; you may have to restart your session if things aren't working
     -- Installing remotes -- (1 of 3. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/Rtmp8YwXXB/4.2'
     (as 'lib' is unspecified)
     trying URL 'https://cloud.r-project.org/bin/windows/contrib/4.2/remotes_2.4.2.zip'
     Content length 398674 bytes (389 KB)
     ==================================================
     downloaded 389 KB
    
     package 'remotes' successfully unpacked and MD5 sums checked
    
     The downloaded binary packages are in
     C:\r_packages\pkgcheck\CRAN\Require\tmp\Rtmp8YwXXB\downloaded_packages
     -- Installing data.table -- (2 of 3. Estimated time left: ...; est. finish: ...calculating)
     Installing package into 'C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/Rtmp8YwXXB/4.2'
     (as 'lib' is unspecified)
     trying URL 'https://www.r-project.org/nosvn/winutf8/ucrt3/CRAN/bin/windows/contrib/4.2/data.table_1.14.2.zip'
     length 2233008 bytes (2.1 MB)
     ==================================================
     downloaded 2.1 MB
    
     package 'data.table' successfully unpacked and MD5 sums checked
    
     The downloaded binary packages are in
     C:\r_packages\pkgcheck\CRAN\Require\tmp\Rtmp8YwXXB\downloaded_packages
     -- Installing Require -- (3 of 3. Estimated time left: 4 secs; est. finish: 2022-01-13 17:37:48)
     Duplicate packages are Required; discarding older, or unavailable
     Package packageFullName keep installResult
     1: data.table data.table TRUE TRUE
     2: data.table data.table FALSE TRUE
     Duplicate packages are Required; discarding older, or unavailable
     Package packageFullName keep installResult
     1: data.table data.table TRUE TRUE
     2: data.table data.table FALSE TRUE
     Detaching is fraught with many potential problems; you may have to restart your session if things aren't working
     .libPaths() is now: C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/Rtmp8YwXXB/4.2, C:/r_packages_ro/rinst/library
     Loading required package: data.table
     .libPaths() is now: C:/r_packages/pkgcheck/CRAN/Require/Require.Rcheck/4.2, C:/r_packages/pkgcheck/lib/4.2, C:/r_packages_ro/rinst/library
     Updating .Rprofile; this will set new libPaths for R packages even after restarting R
     .libPaths() is now: C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/newProjectLib/4.2, C:/r_packages_ro/rinst/library
     removing custom libPaths in .Rprofile
     .libPaths() is now: C:/r_packages/pkgcheck/CRAN/Require/Require.Rcheck/4.2, C:/r_packages/pkgcheck/lib/4.2, C:/r_packages_ro/rinst/library
     .libPaths() is now: C:/r_packages/pkgcheck/CRAN/Require/Require.Rcheck, C:/r_packages/pkgcheck/lib, C:/r_packages_ro/rinst/library
     Placing copy of Require in C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/setupTests
     Placing copy of remotes in C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/setupTests
     Placing copy of data.table in C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/setupTests
     Updating .Rprofile; this will set new libPaths for R packages even after restarting R
     .libPaths() is now: C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/setupTests/4.2, C:/r_packages_ro/rinst/library
     removing custom libPaths in .Rprofile
     .libPaths() is now: C:/r_packages/pkgcheck/CRAN/Require/Require.Rcheck, C:/r_packages/pkgcheck/lib, C:/r_packages_ro/rinst/library
     This is getOption('Require.RPackageCache')
     This is NULL
     Updating .Rprofile; this will set new libPaths for R packages even after restarting R
     .libPaths() is now: C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/setupTests/4.2, C:/r_packages_ro/rinst/library
     removing custom libPaths in .Rprofile
     .libPaths() is now: C:/r_packages/pkgcheck/CRAN/Require/Require.Rcheck, C:/r_packages/pkgcheck/lib, C:/r_packages_ro/rinst/library
     Getting dates of current CRAN packages
     available.packages() does not have correct information on package dependencies for Require because they are Archive versions; downloading their respective tar.gz files
     Called from: (function (pkgURL, pkgTD)
     {
     url <- file.path(repos, srcContrib, "/Archive", pkgURL)
     url2 <- file.path(repos, srcContrib, basename(pkgURL))
     tf <- tempfile()
     haveFile <- suppressWarnings(tryCatch(download.file(url,
     tf, quiet = TRUE), error = function(x) tryCatch(download.file(url2,
     tf, quiet = TRUE), error = function(y) FALSE)))
     if (!file.exists(tf))
     browser()
     untar(tarfile = tf, exdir = dirname(pkgTD))
     filesToDel <- dir(pkgTD, recursive = TRUE, full.names = TRUE,
     include.dirs = TRUE)
     filesToDel <- filesToDel[grep("^DESCRIPTION$", basename(filesToDel),
     invert = TRUE)]
     unlink(filesToDel, recursive = TRUE)
     })(pkgURL = dots[[1L]][[1L]], pkgTD = dots[[2L]][[1L]])
     Browse[1]> debug: untar(tarfile = tf, exdir = dirname(pkgTD))
     Browse[2]> /usr/bin/tar: C\:\\r_packages\\pkgcheck\\CRAN\\Require\\tmp\\Rtmp8YwXXB\\file12d5864f01f56: Cannot open: No such file or directory
     /usr/bin/tar: Error is not recoverable: exiting now
     debug: filesToDel <- dir(pkgTD, recursive = TRUE, full.names = TRUE,
     include.dirs = TRUE)
     Warning message:
     In untar(tarfile = tf, exdir = dirname(pkgTD)) :
     'C:/msys64/usr/bin/tar -xf "C:\r_packages\pkgcheck\CRAN\Require\tmp\Rtmp8YwXXB\file12d5864f01f56" -C "C:/r_packages/pkgcheck/CRAN/Require/tmp/Rtmp8YwXXB/Require/OYJZQT"' returned error code 2
     Browse[2]> debug: filesToDel <- filesToDel[grep("^DESCRIPTION$", basename(filesToDel),
     invert = TRUE)]
     Browse[2]> debug: unlink(filesToDel, recursive = TRUE)
     Browse[2]> Error from message(pkg, " dependencies not found on CRAN; perhaps incomplete description? On GitHub?")
     Error in message(pkg, " dependencies not found on CRAN; perhaps incomplete description? On GitHub?") :
     object 'pkg' not found
     Calls: test_pkg ... pkgDepArchive -> lapply -> FUN -> message -> .makeMessage -> lapply
     Execution halted
Flavor: r-devel-windows-x86_64-new-TK