CRAN Package Check Results for Package Signac

Last updated on 2023-01-27 00:51:15 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.9.0 85.84 406.86 492.70 OK
r-devel-linux-x86_64-debian-gcc 1.9.0 70.73 301.42 372.15 OK
r-devel-linux-x86_64-fedora-clang 1.9.0 650.53 NOTE
r-devel-linux-x86_64-fedora-gcc 1.9.0 603.80 NOTE
r-devel-windows-x86_64 1.9.0 163.00 479.00 642.00 OK
r-patched-linux-x86_64 1.9.0 67.40 385.56 452.96 OK
r-release-linux-x86_64 1.9.0 57.79 385.25 443.04 OK
r-release-macos-arm64 1.9.0 127.00 NOTE
r-release-macos-x86_64 1.9.0 202.00 OK
r-release-windows-x86_64 1.9.0 170.00 458.00 628.00 OK
r-oldrel-macos-arm64 1.9.0 9.00 ERROR
r-oldrel-macos-x86_64 1.9.0 12.00 ERROR
r-oldrel-windows-ix86+x86_64 1.9.0 199.00 717.00 916.00 OK

Check Details

Version: 1.9.0
Check: package dependencies
Result: NOTE
    Imports includes 24 non-default packages.
    Importing from so many packages makes the package vulnerable to any of
    them becoming unavailable. Move as many as possible to Suggests and
    use conditionally.
Flavor: r-devel-linux-x86_64-fedora-clang

Version: 1.9.0
Check: C++ specification
Result: NOTE
     Specified C++11: please update to current default of C++17
Flavor: r-devel-linux-x86_64-fedora-gcc

Version: 1.9.0
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     'chromVAR', 'TFBSTools', 'motifmatchr'
Flavor: r-release-macos-arm64

Version: 1.9.0
Check: Rd cross-references
Result: NOTE
    Packages unavailable to check Rd xrefs: ‘TFBSTools’, ‘motifmatchr’, ‘chromVAR’
Flavor: r-release-macos-arm64

Version: 1.9.0
Check: package dependencies
Result: ERROR
    Package required and available but unsuitable version: ‘GenomeInfoDb’
    
    Packages suggested but not available for checking:
     'chromVAR', 'TFBSTools', 'motifmatchr'
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-macos-arm64

Version: 1.9.0
Check: package dependencies
Result: ERROR
    Package required and available but unsuitable version: ‘GenomeInfoDb’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-oldrel-macos-x86_64