CRAN Package Check Results for Package latrend

Last updated on 2021-04-20 01:47:09 CEST.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.1.2 36.76 569.77 606.53 OK
r-devel-linux-x86_64-debian-gcc 1.1.2 28.86 364.72 393.58 OK
r-devel-linux-x86_64-fedora-clang 1.1.2 705.17 OK
r-devel-linux-x86_64-fedora-gcc 1.1.2 629.30 OK
r-devel-windows-ix86+x86_64 1.1.2 47.00 383.00 430.00 OK
r-devel-windows-x86_64-gcc10-UCRT 1.1.2 ERROR
r-patched-linux-x86_64 1.1.2 35.25 466.54 501.79 OK
r-patched-solaris-x86 1.1.2 871.70 OK
r-release-linux-x86_64 1.1.2 36.14 464.77 500.91 OK
r-release-macos-x86_64 1.1.2 NOTE
r-release-windows-ix86+x86_64 1.1.0 67.00 458.00 525.00 ERROR
r-oldrel-macos-x86_64 1.1.2 WARN
r-oldrel-windows-ix86+x86_64 1.1.2 52.00 415.00 467.00 OK

Check Details

Version: 1.1.2
Check: package dependencies
Result: ERROR
    Package required but not available: 'longitudinalData'
    
    Packages suggested but not available for checking: 'kml', 'akmedoids'
    
    See section 'The DESCRIPTION file' in the 'Writing R Extensions'
    manual.
Flavor: r-devel-windows-x86_64-gcc10-UCRT

Version: 1.1.2
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘mixAK’
Flavors: r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 1.1.2
Check: Rd cross-references
Result: NOTE
    Package unavailable to check Rd xrefs: ‘mixAK’
Flavors: r-release-macos-x86_64, r-oldrel-macos-x86_64

Version: 1.1.0
Check: dependencies in R code
Result: NOTE
    Missing or unexported object: 'akmedoids::akmedoids.clust'
Flavor: r-release-windows-ix86+x86_64

Version: 1.1.0
Check: Rd cross-references
Result: WARN
    Missing link or links in documentation object 'interface-akmedoids.Rd':
     '[akmedoids]{akmedoids.clust}'
    
    Missing link or links in documentation object 'lcMethodAkmedoids.Rd':
     '[akmedoids:akmedoids.clust]{akmedoids::akmedoids.clust}'
    
    See section 'Cross-references' in the 'Writing R Extensions' manual.
Flavor: r-release-windows-ix86+x86_64

Version: 1.1.0
Check: examples
Result: ERROR
    Running examples in 'latrend-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: lcMethodAkmedoids
    > ### Title: Specify AKMedoids method
    > ### Aliases: lcMethodAkmedoids
    >
    > ### ** Examples
    >
    > library(akmedoids)
    > data(latrendData)
    > method <- lcMethodAkmedoids(response = "Y", time = "Time", id = "Id", nClusters = 3)
    Error: 'akmedoids.clust' is not an exported object from 'namespace:akmedoids'
    Execution halted
Flavor: r-release-windows-ix86+x86_64

Version: 1.1.0
Check: tests
Result: ERROR
     Running 'testthat.R' [83s]
    Running the tests in 'tests/testthat.R' failed.
    Complete output:
     > library(testthat)
     > library(latrend)
     > library(data.table)
     > library(kml)
     Loading required package: clv
     Loading required package: cluster
     Loading required package: class
     Loading required package: longitudinalData
     Loading required package: rgl
     Loading required package: misc3d
     >
     > test_check('latrend')
     Loading required namespace: lcmm
     Loading required namespace: flexmix
     Loading required namespace: crimCV
     Loading required namespace: funFEM
     Loading required namespace: lme4
     Loading required namespace: longclust
     Loading required namespace: mixtools
     Loading required namespace: mixAK
     == Skipped tests ===============================================================
     * On CRAN (4)
     * skipping MixTVEM tests because the TVEMMixNormal() function is not loaded (1)
    
     == Failed tests ================================================================
     -- Error (???): (code run outside of `test_that()`) ----------------------------
     Error: could not find function "dataImputation"
    
     [ FAIL 1 | WARN 0 | SKIP 5 | PASS 2811 ]
     Error: Test failures
     Execution halted
Flavor: r-release-windows-ix86+x86_64

Version: 1.1.2
Check: whether package can be installed
Result: WARN
    Found the following significant warnings:
     Warning: 'rgl.init' failed, running with 'rgl.useNULL = TRUE'.
Flavor: r-oldrel-macos-x86_64

Version: 1.1.2
Check: Rd files
Result: WARN
    prepare_Rd: RGL: unable to open X11 display
    prepare_Rd: 'rgl.init' failed, running with 'rgl.useNULL = TRUE'.
Flavor: r-oldrel-macos-x86_64